Mega Man RPG Prototype Bug Reports

Community  »  Bug Reports  » 

Ability Bug : Leaf Shield

March 18th, 2013 at 9:36pm
 
Developer
Adrian Marceau
Adrian Marceau
113,913,695 BP
203 TP | 518 PP
When using the Leaf Shield ability with a very high defense stat, the 30% shield boost end up being capped at 999. This becomes an issue when you throw the shield and the game automatically reduces your defense by a full 30% rather than the actual boost received. This bug is unfortunately part of a bigger problem with the attachment system and not just the Leaf Shield ability, but I have several ideas for how to fix it and I'll update this thread with any progress I make.
Ability Bug : Leaf Shield
Posted by Adrian Marceau on March 18th, 2013 at 9:36pm
Viewed 350 Times

9 Comments

 
Developer
Adrian Marceau
113,913,695 BP
203 TP | 518 PP
Posted on April 27th, 2013 at 12:36am
Posted 2013/04/27 at 12:36am
#1
I just wanted to leave a note here to let you guys know I'm in the process of fixing this bug and adding a whole new set of mechanics in the process! I'm so excited to post about it, but I have to finish a few more sprites first so maybe tomorrow. Oh it's gonna be so great! :D
^ Top
 
Contributor
Brorman
30,135,830 BP
15 TP | 139 PP
Posted on April 29th, 2013 at 9:44am Edited on 2013/04/29 at 9:57am
Posted 2013/04/29 at 9:44am Edited 2013/04/29 at 9:57am
#2
I have a bug to report, unless it had already been fixed.

So, basically all you need is a raised Recovery-% for the field, and you're all set. From that on, Whenever you use Leaf Shield, you won't lose all the defense the recovery gives you. So it's possible to boost your defense with Leaf Shield, and the multiplier doesn't even have to be enormously high to be able to gain big amounts of defense in a couple of turns.

Hopefully I'm not late. Apparently I'm not late: (Screenshot)[http://puu.sh/2JrcF.png]
^ Top
 
Developer
Adrian Marceau
113,913,695 BP
203 TP | 518 PP
Posted on April 29th, 2013 at 10:56am Edited on 2013/04/29 at 2:07pm
Posted 2013/04/29 at 10:56am Edited 2013/04/29 at 2:07pm
#3
Oh man, I was so excited to have fixed this bug with last night's update but I totally forgot about the field multipliers! Luckily this should be an easy fix - something like "do not apply modifiers when damage is a percent" (will not work, need to think of something better) or something like that. Either way, thank you so much for reporting it and I'll try to get it fixed within the next few days (or at least before the weekend).
^ Top
 
Contributor
Brorman
30,135,830 BP
15 TP | 139 PP
Posted on April 29th, 2013 at 12:26pm Edited on 2013/04/29 at 12:30pm
Posted 2013/04/29 at 12:26pm Edited 2013/04/29 at 12:30pm
#4
Doesn't "do not apply modifiers when damage is a percent" also apply to recovery and stat moves? That would totally negate the effect of the whole Recovery Boost ability. I don't know if Recovery boost was intended to boost the effect of stat boosters anyways, well, that's what it does right now.

And no problemo, reporting bugs is pretty fun.
^ Top
 
Developer
Adrian Marceau
113,913,695 BP
203 TP | 518 PP
Posted on April 29th, 2013 at 2:02pm
Posted 2013/04/29 at 2:02pm
#5
You're right, and I definitely need to be very deliberate and careful with the order I calculate this stuff. I definitely do want all the type and recovery/damage boosters to take affect for all moves - even percentages - I just need to make sure the attachment-destroy function knows not to apply them a second or third time. For this specific bug, the Recovery Booster was correct and boosting Wood Man's defense 60% instead of 30%, but I need to tweak the code a bit so that the destory action knows it was boosted. Thanks for excellent bug-testing, and I'll update these threads once I've made some progress. :)
^ Top
 
Contributor
Brorman
30,135,830 BP
15 TP | 139 PP
Posted on April 29th, 2013 at 2:17pm Edited on 2013/04/29 at 2:23pm
Posted 2013/04/29 at 2:17pm Edited 2013/04/29 at 2:23pm
#6
I don't want to make a thread for this little question, but it might be a bug. Shouldn't Damage Booster also boost the damage that Hyper Bomb's additional effect deals to benched robots? Right now the damage seems to be fixed, and can be only changed by the "Bomb" field multiplier (I think). That might lead to major abuse of teamwide hitting moves though.
^ Top
 
Developer
Adrian Marceau
113,913,695 BP
203 TP | 518 PP
Posted on May 30th, 2013 at 11:17am
Posted 2013/05/30 at 11:17am
#7
Alright guys, so it's been a few weeks since the attachment updates and the field multiplier updates and the other bug fixes and I think this bug has been ironed out now. :P Can anyone confirm or deny that this bug has been fixed by their own experiences the last few weeks or should I keep the thread open?
^ Top
 
Shadownnico
26,758,030 BP
13 TP | 176 PP
Posted on May 30th, 2013 at 6:32pm Edited on 2013/05/30 at 6:47pm
Posted 2013/05/30 at 6:32pm Edited 2013/05/30 at 6:47pm
#8
Just tested with a MegaMan with 9999 defense, and a ProtoMan without all that defense, and both worked fine. MegaMan didn't gain nor lost any defense, and ProtoMan gained and lost the same amount. The testing area had a 2x for nature and 1 Recovery Boost. So yea, the bug is fixed.
^ Top
 
Developer
Adrian Marceau
113,913,695 BP
203 TP | 518 PP
Posted on May 30th, 2013 at 10:40pm
Posted 2013/05/30 at 10:40pm
#9
Awesome! Thanks again!
Closing this thread too. :)
^ Top
9 Comments

- comments disabled -

« Back to Home | Mega Man and all related names and characters are © Capcom 1986 - 2017. | Contact & Feedback »
This game is fan-made by Adrian Marceau, not affiliated or endorsed by Capcom at all, and is in no way official. Any and all feedback is appreciated. :)